WANT TO JOIN THE SHORT WING PIPER CLUB?


Results 1 to 3 of 3

Thread: Pitot system problems

  1. #1
    Join Date
    May 2016
    Location
    Hobbs, NM
    Posts
    31

    Default Pitot system problems

    I've read the archives dating from 10 years ago. All of a sudden I've got poor airspeed indicator performance. It's not the instrument. The new one (well, overhauled anyway) reads the same as the old one. The system acts like it's pinched or something. Poor-boy check (A&P blows on pitot tube through a rubber hose) livens the thing up, but normal operations, well I missing about 50 kts (new instrument outer ring is kts). Thing barely comes alive during take-off run (home plate is at 3,660'), shows climb at full power 500 fpm 44 kts, cruise climb 250-300 fpm 50 kts, Level cruise 2500 rpm 7,500' 55 kts. Ground speed no wind cond. (rare for these parts, but today was), 103 kts. at 2500 rpm 7,500' - about what I'm used to. Well, maybe it wasn't so all of a sudden. In May we went in to the shop for a new interior, and exterior rehab including paint - which involved pulling ailerons, rudder, and elevator. Any response appreciated. Thanks. Dennis

  2. #2
    Join Date
    Nov 2006
    Location
    Mason, Ohio
    Posts
    284

    Default

    Dennis,

    My guess is that you have either a blockage or a leak in the pitot system or a blockage in the static system. The air speed instrument is a sealed container. The pitot air pressure enters the instrument into a diaphragm that moves the needle. The static pressure enters the instrument through a port on the back and surrounds the diaphragm so what the diaphragm actually measures is the difference between pitot pressure and static pressure. I would strongly suspect a leak in the pitot leading to the air speed instrument. Some of those old rubber lines connecting the aluminum tubing can crack and cause leakage of the dynamic pressure.

    Tom

  3. #3
    Join Date
    May 2016
    Location
    Hobbs, NM
    Posts
    31

    Default

    Thanks for the reply. My feeling is that it is leaking somewhere, and I'm thinking near the root of the pitot tube itself. The pitot tube came off for the paint job and was "rewelded" or something as Harry said it was "hanging loose" before (when it worked right, or at least displayed numbers close to, if some less than, book). I know I can get a replacement pitot tube from UNIVAIR, but can all the tubing be replaced without ripping up the wing fabric?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

 

Home | Officers | Chapters | Members | Classifieds | Conventions